Monday, March 15, 2010

Running .NET 4.0 in IIS 7.5 for the First Time

Today, I tried my hand at running an asp.net 4.0 (release candidate) web app for the first time in IIS 7.5.  I was getting all kinds of errors, the latest one being
Handler "PageHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list
Anyhow, I thought I’d mention on this blog how I got it working.   Turned out .Net Framework 4.0 was not registered properly.  After I did run %windir%\Microsoft.NET\Framework\v4.0.21006\aspnet_regiis.exe –i, everything is working fine.

1 comment: